Jeep Renegade Forum banner

1 - 20 of 26 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I just cleaned up my barely 2 month old Trailhawk to discover some minor undercarriage trim damage. Yes, I remember hitting that chunk of concrete while testing out the 4wd capabilities last week. Broken in now I guess. I could never get the 4wd to self-engage in Auto mode however. What does it take for that?
Finally hit 17mpg's...yippie! Sticker says 24 (Bit disappointed/confused bout the fuel economy statements). Luvin it anyway, my mobile job site office has all the bells & whistles I need.
 

·
Registered
Joined
·
15 Posts
It has been suggested to me. That I could have the underbelly especially any exposed framework sprayed with a bedliner. It would help prevent damages, as well as any rust. I have not yet had the time to see one on the rack in the garage. But I intend on doing so. Cause I'm interested in seeing it doing a underbelly spray would make any since.
I'll look into the auto mode and it engaging the 4wd. Monday when I get to the shop. As far as official break in period. Personally I would go with 500-1,000 miles.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Sounds like u r a dealership mechanic? Great resource. Don't think an undercoating would have prevented this damage to the plastic trim. Actually tore @ one of the securing bolt locations. Anyway, what are u getting in gas mileage...assuming you have Trailhawk also. I am only getting 16.7-17mpg?!
 

·
Registered
Joined
·
15 Posts
Not a certified mechanic myself but I work with them in the service garage. And my Thawk isn't set to arrive until the Wk of 12/21. I will be making wkly post on my updated mileage, and fuel efficiency.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Oh. Gotcha. Yeah, I waited 14 weeks for mine. Had it built because I needed the Tow pkg.
Anyone else out there have any MPG experience to share?
 

·
Registered
Joined
·
15 Posts
Customer who bout the first Thawk we had is reporting 20/25 in town. And 28/30 highway.
She is over 6k miles, so cleared break in period.
 

·
Registered
Joined
·
21 Posts
Customer who bout the first Thawk we had is reporting 20/25 in town. And 28/30 highway.
She is over 6k miles, so cleared break in period.
Diff motor n Trans but my 1.4L turbo 6spd gets 22.5 around town 26.9 highway
4450 miles on it. Gotta say I love the TH. But the 2.4 and auto Trans felt sluggish to me. The turbo motor is much more fun to drive in my opinion. Just an opinion.
 

·
Registered
Joined
·
24 Posts
Traded my 2006 Wrangler in for my 2015 Renegade Lattitude 4x4 .
Did not use my Wrangler off road .
After viewng the under carriage of this Renegade as compared with the Wrangler , I would hesitate
to go too far off road with it .
Renegade is steel tubes where the Wrangler was solid steel everywhere .
Renegade looks sharp and getting 26mpg avg compared to the 19mpg Wrangler .
Definetly Fiat with a US engine & trans.
 

·
Registered
Joined
·
19 Posts
Have trailhawk less than 1000 miles but have been getting 26 mpg on every tank! Mine has metal skid plates vrs plastic on 2011 Wrangler Sahara I traded ( which got maybe 18 mpg on a good day ). Heard engine and tranny both Fiat designed. Also would not do serious offroading ( did't in Sahra either) Reese makes easy to install hitch, comes out under bumper. Don't have one yet but will soon.
 

·
Registered
Joined
·
24 Posts
Getting about 26 mpg on my 2015 Lattitude 4x4 , under 1000 miles on it .
Sticker says engine & trans made in USA but rest of car is Fiat .
Time will tell if this was a smart purchase . I don't expect the excellent trade in value that
my 2006 Wrangler got.
 

·
Registered
Joined
·
19 Posts
Didn't get as good a trade on my 2011 Wrangler when traded on Renegade as I did when I traded my 98 Wrangler on the 2011, but agree trade in and resale may not be as good on Renegade.
 

·
Registered
Joined
·
3 Posts
Oh. Gotcha. Yeah, I waited 14 weeks for mine. Had it built because I needed the Tow pkg.
Anyone else out there have any MPG experience to share?
I have the Trailhawk (love it ), but, when I bought it I took it upstate 5-6 times & got 29.5 to 30 mpg. back & forth to work I was getting 23 to 25 mpg. I'm having a camera problem since I bought the truck in August so I brought it in to " repair it ". They said they had to do an "upgrade" on it & since then it's been down hill. I now get at the most 20 on the road & back & forth to work about 16. For this I could have kept my Wrangler which was great. Besides loosing my gas milage my tranny now shifts like crap. It no longer starts off in 1st gear it starts in 2nd & they are telling me that's normal now, it's not. It also shifts when it wants to from 7th to 9th. I have spent over 20 hrs. waiting in the waiting room to keep getting it back the same way & the back up camera still doesn't work all the time. The last time I finally got a loner car & they had mine for 6 days, the tranny shifts a little better but still no first gear & still shifts sloppy 2nd to 3rd & 3rd to 4th & still no gas milage & camera still the same. (by the way they replaced the camera & the radio & I was told they don't know what else to do ). Any one have any of these issues or suggestions on what to do I'm at my whitts end. THANK YOU Bill
 

·
Registered
Joined
·
24 Posts
I have the Trailhawk (love it ), but, when I bought it I took it upstate 5-6 times & got 29.5 to 30 mpg. back & forth to work I was getting 23 to 25 mpg. I'm having a camera problem since I bought the truck in August so I brought it in to " repair it ". They said they had to do an "upgrade" on it & since then it's been down hill. I now get at the most 20 on the road & back & forth to work about 16. For this I could have kept my Wrangler which was great. Besides loosing my gas milage my tranny now shifts like crap. It no longer starts off in 1st gear it starts in 2nd & they are telling me that's normal now, it's not. It also shifts when it wants to from 7th to 9th. I have spent over 20 hrs. waiting in the waiting room to keep getting it back the same way & the back up camera still doesn't work all the time. The last time I finally got a loner car & they had mine for 6 days, the tranny shifts a little better but still no first gear & still shifts sloppy 2nd to 3rd & 3rd to 4th & still no gas milage & camera still the same. (by the way they replaced the camera & the radio & I was told they don't know what else to do ). Any one have any of these issues or suggestions on what to do I'm at my whitts end. THANK YOU Bill
Since they are telling you that "they don't know what else to do" , it may be time to use the Lemon Law ?
 

·
Registered
Joined
·
21 Posts
So sorry to hear this and your going thru it.. so glad I got the 6spd manual..your not the 1st horror story I heard w/the shifting. Too be honest when I test drove a trailhawk I hated the trans.. and was bummed..then I drove the manual and the rest is history. Haven't heard anything about the camera tho
 

·
Registered
Joined
·
12 Posts
I was wondering if you have any update? Mine is currently at the dealer, they have done 4 updates but I have not had it back to drive yet. I am looking at maybe having to go Lemon Law with mine sadly. But for a problem different than yours.

I have the Trailhawk (love it ), but, when I bought it I took it upstate 5-6 times & got 29.5 to 30 mpg. back & forth to work I was getting 23 to 25 mpg. I'm having a camera problem since I bought the truck in August so I brought it in to " repair it ". They said they had to do an "upgrade" on it & since then it's been down hill. I now get at the most 20 on the road & back & forth to work about 16. For this I could have kept my Wrangler which was great. Besides loosing my gas milage my tranny now shifts like crap. It no longer starts off in 1st gear it starts in 2nd & they are telling me that's normal now, it's not. It also shifts when it wants to from 7th to 9th. I have spent over 20 hrs. waiting in the waiting room to keep getting it back the same way & the back up camera still doesn't work all the time. The last time I finally got a loner car & they had mine for 6 days, the tranny shifts a little better but still no first gear & still shifts sloppy 2nd to 3rd & 3rd to 4th & still no gas milage & camera still the same. (by the way they replaced the camera & the radio & I was told they don't know what else to do ). Any one have any of these issues or suggestions on what to do I'm at my whitts end. THANK YOU Bill
 

·
Registered
Joined
·
3 Posts
I was wondering if you have any update? Mine is currently at the dealer, they have done 4 updates but I have not had it back to drive yet. I am looking at maybe having to go Lemon Law with mine sadly. But for a problem different than yours.
Last time I got it back it shifted great for the first 3 weeks, then it started slamming into gear. Was all set to go back again & it started to shift good again. Lasted about 1 week and started to slam into gear again. now it's intermitting & won't do it when I want to bring it back. As far as gas milage I still can't get over 21 no matter what I do. The manager tells me the government puts something in the fuel doing the winter months & that is why my milage is low. Well it's June now & I still can't get over 21 mpg. ( very hard to believe the government puts something in the fuel to make you loose 9 to 10 miles per gallon ). At this point I'm not sure what to do Cause I really do like this car otherwise. Bill
 

·
Registered
Joined
·
12 Posts
Last time I got it back it shifted great for the first 3 weeks, then it started slamming into gear. Was all set to go back again & it started to shift good again. Lasted about 1 week and started to slam into gear again. now it's intermitting & won't do it when I want to bring it back. As far as gas milage I still can't get over 21 no matter what I do. The manager tells me the government puts something in the fuel doing the winter months & that is why my milage is low. Well it's June now & I still can't get over 21 mpg. ( very hard to believe the government puts something in the fuel to make you loose 9 to 10 miles per gallon ). At this point I'm not sure what to do Cause I really do like this car otherwise. Bill
I had to take mine on a very long road trip, finally got it up to 28.5 - would not budge beyond that. On the trip home it would not go above 27. both are averages. Before all the updates it would get up to 34, even with surface streets. Before the road trip (and after all the updates) it would not budge above 19.5.
 

·
Registered
Joined
·
7 Posts
We only have 450 miles on ours and haven't really paid attention to mpg's yet, but sounds like i will refuse the "updates" when i take it to dealer.Still breaking in but has shown 23mpg so far. Will be taking it on a trip in September going from Ohio to Missouri and should have around 1500 miles on it by then and will let ya know mpg's from trip.
 

·
Registered
Joined
·
1 Posts
I got my 2016 TH last Dec and I have 7200 km (~4500 miles) on it so far. I drove it 60% highway, 30% city and 10% off-road and my overall average is 10.5 l/100km (~22.4 US mpg). Did get as high as 30 mpg on highways. Never had an upgrade and I'm quite happy with my Reny so far. TH is only automatic but I do not have the problems with shifting others seems to have, and the 4x4 engages flawlessly in the Auto mode, when needed, in off road conditions (maybe the 2016 model improved software is the reason). The complains I have (so far) are: 1) loosing of the guide-lines for the back camera from time to time (have to put them back in settings), 2) in 4WD Lock after an hour or so of relatively steep up-hill off-roading (with frequent very low speed portions), even though engine temperature is normal, it seems it needs harder and harder push on the gas pedal to get the traction you need...(I suspect a software problem, but would appreciate a comment from others who experienced this issue) and 3) even though in 4WD Low range and first gear, when going downhill, engine compression drag is not enough and frequent braking is still needed to control the speed, but when using Hill Descent Control option, the speed seems to be too slow...maybe I'm doing something wrong here? Comments?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #20 ·
Hey gang. Been a while. I got 'barked at' for not keeping up. Thanks for that...needed the wake up call to realize my priorities have been out of whack.
11 months in hammering the 9 speed auto THawk...turned 16k miles this week. Mostly jobsite running.
Achieving 19mpg according to the info center on the dashboard (bit better than the 16 was complaining about).
Still off from the sticker avg of 24.
Sorry that this is not really a reply to vlad above. I cannot say that our terrain here in FL is comparable to Canada (no uphill/downhill round here) Do have plenty of mud/sand this summer...hey maybe I can get the 4WD to self-engage in Auto Mode! Gotta try that this week
 
1 - 20 of 26 Posts
Top