Jeep Renegade Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Has anyone had a problem with the "Service Engine" light coming on? From what the Dealer/Service tells me is that is giving them "Codes" and that they are working the Codes (I don't know the exact Codes), but every time they have it "Fixed" (Reprogrammed), I take it home I get the "Service Engine Light" and end up bringing it back. I bought it (2015 Jeep Renegade Latitude 4X4) "Certified Used" Dec 29, 2016. As of today, Feb 2, 2017 they've been working on it more than I've gotten to drive it. It's had something to do with the Transmission Control as the Mode Select is inoperative. So I've never even been able to try 4 Wheel Drive as it hasn't worked long enough for me to try.
Is this a One-in-a-Million or has anyone else had similar problems?

So far they've done:
1. Ordered and replaced the "Control Module".
2. Reprogrammed computer.
3. Replaced the New Control Module.(Suspected that it was defective.)
4. Reprogrammed Computer.
5. Ordered, replaced and reprogrammed 3rd Control Module. (2nd one was for a FWD Model)
 

·
Registered
Joined
·
44 Posts
Has anyone had a problem with the "Service Engine" light coming on? From what the Dealer/Service tells me is that is giving them "Codes" and that they are working the Codes (I don't know the exact Codes), but every time they have it "Fixed" (Reprogrammed), I take it home I get the "Service Engine Light" and end up bringing it back. I bought it (2015 Jeep Renegade Latitude 4X4) "Certified Used" Dec 29, 2016. As of today, Feb 2, 2017 they've been working on it more than I've gotten to drive it. It's had something to do with the Transmission Control as the Mode Select is inoperative. So I've never even been able to try 4 Wheel Drive as it hasn't worked long enough for me to try.
Is this a One-in-a-Million or has anyone else had similar problems?

So far they've done:
1. Ordered and replaced the "Control Module".
2. Reprogrammed computer.
3. Replaced the New Control Module.(Suspected that it was defective.)
4. Reprogrammed Computer.
5. Ordered, replaced and reprogrammed 3rd Control Module. (2nd one was for a FWD Model)
Hi Brian,

I'm really sorry you've had this experience with your Renegade. Do you know if your dealership has reached out to corporate techs for additional support?

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
They (Dealer/Service) said they were getting some directions from Corporate Tech.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 · (Edited)
Excellent! That's the answer I was hoping for--if you would like me to do any additional follow up, please let me know. I would just need your VIN in a PM.

Kori
Jeep Social Care Specialist
I'm not sure how to PM from this site........
I'm sure that they are doing the best they can. If I need additional help I'll reply on this this post. But for now I'll let the Dealer/Service try to work it out. Thank you for your input.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #6 ·
After an exhausting troubleshooting day (or 2) they also found out, from Corporate Tech Support, that it could be a Service Bulletin related problem with the Thermostat (sending unit/portion) that could be triggering bogus info to the computer resulting in erroneous information and sending more codes out including the Mode Selector code issue making the Service Engine Light come on.
Parts are on order, more to follow when parts arrive, stay tuned...........
 

·
Registered
Joined
·
10 Posts
Service engine light came on at 9973 miles. Took it in was told updates needed. They did them, knocked out code. This is when blare of horn began. Light came back on at 10793 miles. This time they acknowledged code as thermostat. Kept her for a week due to back order. Waiting for BCM, on back order until April. Waited almost 5 months for back ordered windshield when I got smucked by a highway rock.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Part came in!! They (Dealer/Service) replaced the Thermostat and reprogrammed (Flashed) the computer, NO Service Engine light. I took it for a road test (as well as the Dealer) and Presto...NO Light.
I'll update this thread if it comes back, hopefully this will fix it.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #9 ·
Well, back to the shop we go. Now that it seems the "Service Engine Light" has gone away, a new light comes on. The warning light that tells you when you have "Lights" that aren't functioning. Such as these that I get: Driving Light Out, Left Brake Light out, Turn Signal Out, Left Rear Courtesy Light Out and a couple more that I can't recall right now. These illuminated at start up, I checked the lights, they were all functioning as they should. After about 5 minutes down the road the Warning Light goes out. After a short stop and restarting the Jeep, the Warnings came back and again, lights were actually working and again, about 5 minutes down the road the Warning Light went out again. So, yet another day @ the Dealer/Service to see what's going on. I'm sure they would rather spend their time on something else, but to e it looking like a wiring issue (loose/faulty connection) somewhere.
I'll update after the troubleshooting..........
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
After troubleshooting, they loaded the latest "Updates" and all is well.
Hopefully there won't be anymore software issues.
It was actually warm enough (and dry enough) to try the retractable roof, the grandkids were awe-struck when I picked them up from school.
 

·
Registered
Joined
·
8 Posts
I had the same problem twice, hope you don't get it again. Mine was a software fix ...........supposedly, for the thermostat. They loaded the software and the light came on again the next day. Brought it back and it was the thermostat that was " defective" and from what I was told it is happening like crazy with alot of these vehicles. Of course I had to bring it back a 3rd time because they had to order the thermostat and of course I had to leave it over the weekend because they didn't have the part in stock. Never buying a renegade ever again unless they start building them in the states like they used to. Other problems as well......car is borderline lemon.
 

·
Registered
Joined
·
8 Posts
UPDATE: engine light came on. Noticed alot of really strange things with the interior and exterior lights going on and off by themselves. I thought it was a software of computer problem but they said it "needed a new alternator" and they supposedly replaced it. Makes no sense at all. I'm sorry to say this because I know that there are staunch fans of this vehicle, but it is ABSOLUTELY BY FAR............the worst car I have ever owned and will not lease it again. In fact I am going to another dealership next week to see if they will buy out the car from the lease company. I'm done with bringing this to the dealer every few months.
 

·
Registered
Joined
·
1 Posts
Took my 2015 Renegade Latitude in to the dealership this weekend as it hit 50,000 miles along with a Service Engine warning and a Check Engine light. The dealership said it was the transmission module that needed reprogramming. The light came back on after two days. Now they’re saying it’s the thermostat and will cost me $400 minimum.
 

·
Registered
Joined
·
44 Posts
Took my 2015 Renegade Latitude in to the dealership this weekend as it hit 50,000 miles along with a Service Engine warning and a Check Engine light. The dealership said it was the transmission module that needed reprogramming. The light came back on after two days. Now they're saying it's the thermostat and will cost me $400 minimum.
If your Renegade is currently in service at the dealership, I'd be happy to get a case opened for you on our end to see if there is any further assistance we can offer to you or the dealership during the repair. Please send a PM with your VIN if you're interested.

Kori
Jeep Social Care Specialist
 

·
Registered
Joined
·
8 Posts
New problem. Heard strange squeeking sound , passenger side coming from somewhere under the wheel well. Brought it in to the dealership. It needed a strut and strut bearing. The vehicle has under 27k on it and it already needs a new strut and strut bearing? really? how are these cars built? and what are they built with?. My wife drives this vehicle and she drives it like an old lady. This is ridiculous. I also have a Toyota FJ Cruiser. 2007 and it has 123k on the odo. I never had any problem with any bearings and I drive the vehicle off road atleast twice a year, hard. Anyway, to continue.............we brought it in to the dealership, they said they had to order the parts and that the strut bearing would not be in TILL MAY!.............but the service manager told me to call Customer Care and open a case, which I did. The parts finally came in after a couple weeks, so they said. Brought the vehicle back and they said it would take a few days to fix. Gave us a loaner car. Picked up the car in a few days, squeek was gone but now there is a new problem. We brought it back and they said it was a broken engine mount. So they put that part on order now. After driving the vehicle for another week, the squeek is back at the strut/bearing , same as before, which leads me to believe that nothing was ever fixed OR the parts are just really poorly made. Anyway, it's back in the shop and the are supposedly installing a new engine mount and going to take a look at what the problem is with strut and strut bearing. I give up. I am glad that this was just a lease. I have this hunk of garbage till november according to the lease. In a couple months I am going to try and trade in this thing for a real vehicle, a Subaru Crosstrek and I don't care if I have to shell out significant cash in order for them to buy it out. I need to get rid of this vehicle. It's not safe IMO. I will never buy a jeep (FIAT) ever again. They ruined the Jeep brand and it's sad because I have been driving Jeeps since the early 80's. They trashed this name forever. There were other problems but I am tired and don't feel like typing anymore. The more I read about this vehicle the more I learn that it's really not reliable in any way, shape or form.
 
1 - 15 of 15 Posts
Top